Magellan Linux

Annotation of /tags/mkinitrd-6_1_12/busybox/examples/busybox.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 939 - (hide annotations) (download)
Tue Nov 17 21:24:51 2009 UTC (14 years, 7 months ago) by niro
File size: 1224 byte(s)
tagged 'mkinitrd-6_1_12'
1 niro 532 %define name busybox
2     %define epoch 0
3     %define version 0.61.pre
4     %define release %(date -I | sed -e 's/-/_/g')
5     %define serial 1
6    
7     Name: %{name}
8     #Epoch: %{epoch}
9     Version: %{version}
10     Release: %{release}
11     Serial: %{serial}
12     Copyright: GPL
13     Group: System/Utilities
14     Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
15     URL: http://busybox.net/
16     Source: ftp://busybox.net/busybox/%{name}-%{version}.tar.gz
17     Buildroot: /var/tmp/%{name}-%{version}
18     Packager : Erik Andersen <andersen@codepoet.org>
19    
20     %Description
21     BusyBox combines tiny versions of many common UNIX utilities into a single
22     small executable. It provides minimalist replacements for most of the utilities
23     you usually find in fileutils, shellutils, findutils, textutils, grep, gzip,
24     tar, etc. BusyBox provides a fairly complete POSIX environment for any small
25     or emdedded system. The utilities in BusyBox generally have fewer options then
26     their full featured GNU cousins; however, the options that are provided behave
27     very much like their GNU counterparts.
28    
29     %Prep
30     %setup -q -n %{name}-%{version}
31    
32     %Build
33     make
34    
35     %Install
36     rm -rf $RPM_BUILD_ROOT
37 niro 816 make CONFIG_PREFIX=$RPM_BUILD_ROOT install
38 niro 532
39     %Clean
40     rm -rf $RPM_BUILD_ROOT
41    
42     %Files
43     %defattr(-,root,root)
44     /